エルダー・スクロールズ・オンライン ファイアソング

コミュニティ

8480.VotansMiniMap エラー
[Grotear] 2022/12/30 09:15 質問
VotansMiniMap がエラーがでます

user:/AddOns/LibAsync/LibAsync.lua:10: Cannot find a library instance of "LibAsync".
stack traceback:
user:/AddOns/jpfont/libs/LibStub/LibStub.lua:27: in function 'LibStub:GetLibrary'
|caaaaaa<Locals> self = [table:1]{minor = 2}, major = "LibAsync" </Locals>|r
user:/AddOns/LibAsync/LibAsync.lua:10: in function '(main chunk)'
|caaaaaa<Locals> MAJOR = "LibAsync", log = [table:2]{enabled = T, originalTag = "LibAsync", tag = "LibAsync"}, dbg = user:/AddOns/LibAsync/LibAsync.lua:3, warn = user:/AddOns/LibAsync/LibAsync.lua:6 </Locals>|r


user:/AddOns/VotansMiniMap/PinSizes.lua:55: attempt to index a nil value
stack traceback:
user:/AddOns/VotansMiniMap/PinSizes.lua:55: in function 'AddPin'
|caaaaaa<Locals> pinType = 0, caption = "Player", stringId = 9584, pinData = [table:1]{mouseLevel = 0, texture = "EsoUI/Art/MapPins/UI-WorldMapP...", size = 16, level = 170} </Locals>|r
user:/AddOns/VotansMiniMap/PinSizes.lua:113: in function 'addon:InitPinSizes'
|caaaaaa<Locals> self = [table:2]{name = "VotansMiniMap", isSpecialZoom = F}, LibHarvensAddonSettings = [table:3]{ST_CHECKBOX = 1, ST_COLOR = 5, ST_EDIT = 3, ST_LABEL = 7, ST_SLIDER = 2, version = 10900, ST_BUTTON = 6, ST_DROPDOWN = 4, ST_SECTION = 8}, settings = [table:4]{mouseOver = F, name = "Votan's Mini Map Pin Sizes", selected = F, allowDefaults = T}, othersScale = 1, UpdatePin = user:/AddOns/VotansMiniMap/PinSizes.lua:35, UpdateDrawLevel = user:/AddOns/VotansMiniMap/PinSizes.lua:38, UpdateDrawLevels = user:/AddOns/VotansMiniMap/PinSizes.lua:44, AddPin = user:/AddOns/VotansMiniMap/PinSizes.lua:51, AddPins = user:/AddOns/VotansMiniMap/PinSizes.lua:78, AddCustomPin = user:/AddOns/VotansMiniMap/PinSizes.lua:108 </Locals>|r
user:/AddOns/VotansMiniMap/PinSizes.lua:249: in function 'PlayerActivated'

だれか分かりますか?

LibAsyncを一回オフにしてしまって、オンにしてもエラーが出ます

  • [qyt03676] 2023/01/05 21:28
    ざっと見た感じでは「jpfont」アドオンに内包されている「LibStub」が悪影響を及ぼしているように見受けられます。
    現在の ESO アドオン環境において LibStub の役目は終わっており、ライブラリとして LibStub を参照することは避けるよう言われています。

    解決の試みとしては、まず jpfont フォルダ内にある「libs」フォルダの名称を変更、あるいは削除します。
    次いで、依存関係にある「LibMediaProvider」の最新のものを別途インストールしておきましょう。
    jpfont アドオンの設定ファイルを見ると LibStub はあくまで補助的な依存にとどまっているようなので、このまま LibStub を無視して利用できるはずです。

    ざっと見た印象に基づく推測なので完全な解決策ではないと思われますが、何かの参考となりましたら幸いです。
    無事のご解決を心よりお祈り申し上げます。